Login Register
Telink BDT commands
Nov 06, 2022 13:49




In the Help of the Telink BDT there is only the following information about commands used in Command Line:

* -Command :
* wf/rf: write/read flash
* wc/rc: write/read core including sram and digital register
* wa/ra: write/read analog register
* wo/ro: write/read otp
* help/ac/rst/pc
* -optional Command : -i -o -s -u -e -f -c
* 8258 wf 0 -i "C:\Users\Administrator\Desktop\Telink.bin" -u
* 8258 wf 0 -s 512k -e -u
* 8258 wf 0 01 02 -s 2 -u
* 8258 rf 0 -s 12k -u -o "C:\Users\Administrator\Desktop\Telink.bin"
* 8258 wc 8000 -i "C:\Users\Administrator\Desktop\Telink.bin" -u
* 8258 wc 0 00 -s 1 -u
* 8258 rc 0 -s 12k -u -o "C:\Users\Administrator\Desktop\Telink.bin"
* 8258 wo 0 -i "C:\Users\Administrator\Desktop\Telink.bin" -u
* 8258 wo 0 00 -s 1 -u
* 8258 ro 0 -s 12k -u -o "C:\Users\Administrator\Desktop\Telink.bin"
* 8258 rst -f/-c -u
* 8258 sws b0 10 b0 10(only support evk mode)
* 8258 ac (only support evk mode)

* 8258 pc -i "C:\Users\Administrator\Desktop\Telink.lst" -u
* 8258 pc -u
* 8258 log usb 1 -u

There is no information about the -optional Command : -i -o -s -u -e -f -c

Can you provide information about each of these commands?

What are ac, pc, rst commands?

7 replies
TL_Soyo Nov 07, 2022 11:00


  please reference AN-18101500-E2_Telink Cmd_Download_Tool User Guide.pdf under \BDT\doc\ path.

wes58 [Author] Nov 07, 2022 13:45

Ok. I found it there. Although it is not listed in some order you have to go through the whole document to find something.

A week or so ago I asked how to copy/transfer data from Gateway to another chip.

If I want to do that, I think I should change the new Gateway IEEE/MAC address which is stored at 0xFF000.

1. I try to write 8 bytes to this memory address and I get:

TC32 EVK : Swire OK
[173]: wait for ack err!
Flash Bytes Program Error at address ff000

But when I read this address the data has changed, but not what I tried to write.

How can I do it?

2 I try to write data that I read from old gateway to address 0xE0000 using the following command:

8258 wf E0000 -i "E:\Telink\BDT\LE0000.bin"

But I get the following error:

[124]: open sram file err!

What does it mean? What am I doing wrong?

wes58 [Author] Nov 07, 2022 14:00

Issue solved!

I should have tried more options.

1. Instead of writing 8 bytes in BDT, I wrote it via command line and data stored in a file:

B85 wf FF000 -i "E:\Telink\BDT\LFF000.bin"

But I still don't know, why can't I write 8 bytes (I even tried to write 1 byte) to this address

in BDT Memory Access. Writing to different address is no problem.

2. The problem solved because I noticed that in the latest BDT it is using B85 instead of 8258

So I had to use:

B85 wf E0000 -i "E:\Telink\BDT\LE0000.bin"

In BDT help it is still showing * 8258 wf 0 -i "C:\Users\Administrator\Desktop\Telink.bin" -u

TL_Soyo Nov 07, 2022 15:48

you dont need use cmd to r/w ,we have BDT tool ,plese refrence AN-18101201-C3_Telink Burning and Debugging Tool (BDT) User Guide.pdf

wes58 [Author] Nov 07, 2022 16:05

I used "Command Line Input" in BDT to write to bigger area.

And "Memory Access" in BDT to read.

As I wrote before, trying to write 8 bytes to Flash address 0xFF000 to change IEEE address/MAC address gave me an error.

I had to put data in the file and then write it from the .bin file.

TL_Soyo Nov 08, 2022 10:14

try unlock ,and modify mac again,

wes58 [Author] Nov 08, 2022 13:21

I think I tried to use Unlock button and the message was that unlock was successful but it didn't work.

As I wrote, the data that was written wasn't either original IEEE address or the new address that I tried to write.  So something was written but it wasn't correct.

When I tried to write to different Flash address it wrote correctly.

Anyway, it worked for me when I put the data in the .bin file and wrote to flash through command line input

I tested the gateway with copied data from the old chip, and it works OK - all nodes info is there and I can control the devices. So I am happy that I could do it, and didn't have to reset all devices.

Thanks for your help.