Login Register
BLE LT SDK demo app with 8269 EVK modules
Oct 31, 2017 23:59




I'm trying to run the test app bundled with telink_ble_sdk_release_v3.1.0_20170509.rar:

1) I am programming my targets EVKs with a TLSR8266 burning EVK (the one with USB-mini and USB-A in diagonal on the PCB).

2) HOST: I compile 8269_master_kma_dongle target and download built 8269_master_kma_dongle.bin on a TLSR8269 dev EVK module (the one with mini-SUB and USB-A aligned on the PCB).

3a) SLAVE BLE: I compile 8269_remote_ble target and download built 8269_remote.bin on a second TLSR8269 dev EVK.

3b) SLAVE BLE: Alternatively I compile 8269_module target and download built 8269_module.bin on a second TLSR8269 dev EVK.

4) I connect the first HOST module on the PC with USB. It is recognized by Telink Bulk app, displays -- Found.

5) I connect the HOST and SLAVE: 3.3V, GND, UTX, URX, G3 and G2 to 3.3V, GND, URX, UTX, G3 and G2 (all straight except UTX and URX). I also tried crossing G2 and G3.[/list]

PROBLEM: Though the HOST module is found, no command gets sent (there's no answer). Apparently the communication with the SLAVE module is faulty !

Can you help solve this !? Have you certified the SDK example with 8269 ? Are there some changes not reflected in the documentation ?

Thank you for your prompt help
1 replies
TL_yuzhong Nov 29, 2017 17:34
These problems may not be solved easily by the forum, need to connect your agent and get the support.
Related topics
No related topics
Author's other topics
Understanding wtcdb